公式吧 公式吧大智慧公式、大智慧股票公式.域名www.gongshi8.com公式吧

loadding...

大智慧十天买卖主图 十天买卖指标公式源码

发布时间: 2016-12-23 20:56

大智慧十天买卖主图 十天买卖指标公式源码

大智慧十天买卖主图 十天买卖指标公式源码

SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

DRAWTEXTREL(800,40,'量能饱和度:'+NUMTOSTRN(SAT,0)),LINETHICK2,Color00FFFF;

B1:='^^^^^^^^^^^^^^^^^^^^^^^^';

DRAWTEXT(vol=HHV(vol,20),C ,B1),color00FFCC;

十天买卖:ema(REF(CLOSE,1),2),COLORFFCC00,LINETHICK1;

PARTLINE(十天买卖,CLOSE>=十天买卖,RGB(255,0,0)),LINETHICK4;

十天压力:HHV(十天买卖,13),COLOR00FF00,LINETHICK1;

PARTLINE(十天压力,十天买卖=十天压力,RGB(255,255,0)),LINETHICK3;

十天支撑:LLV(十天买卖,13),Color00FFFF,LINETHICK1;

PARTLINE(十天支撑,十天买卖=十天支撑,RGB(0,0,255)),LINETHICK3;

RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=((3 * K) - (2 * D));

RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

K24:=SMA(RSV24,3,1);

D24:=SMA(K24,3,1);

J24:=((3 * K24) - (2 * D24));

压力位:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),color0000FF;

支撑位:IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24)))),colorFF0000;

价在线下:=C<十天买卖;

STICKLINE(价在线下 ,CLOSE ,OPEN,7.5,0 ),COLORff7700;

STICKLINE(价在线下 ,CLOSE ,OPEN,6,0 ),COLORff9900;

STICKLINE(价在线下 ,CLOSE ,OPEN,5,0 ),COLORffbb00;

STICKLINE(价在线下,CLOSE ,OPEN,4,0 ),COLORffcc00;

STICKLINE(价在线下,CLOSE ,OPEN,3,0 ),COLORffdd00;

STICKLINE(价在线下 ,CLOSE ,OPEN,2,0 ),COLORffee00;

STICKLINE(价在线下,CLOSE ,OPEN,1,0 ),COLORffff00;

价在线上:=C>=十天买卖;

STICKLINE(价在线上,CLOSE,OPEN,7.5,0) ,COLOR000055;

STICKLINE(价在线上,CLOSE,OPEN,6,0) ,COLOR000066;

STICKLINE(价在线上,CLOSE,OPEN,5,0) ,COLOR000077;

STICKLINE(价在线上,CLOSE,OPEN,4,0) ,COLOR000099;

STICKLINE(价在线上,CLOSE,OPEN,3,0) ,COLOR0000bb;

STICKLINE(价在线上,CLOSE,OPEN,2,0) ,COLOR0000dd;

STICKLINE(价在线上,CLOSE,OPEN,1,0) ,COLOR0000ff;

收小于开:=C>=十天买卖 and c

stickline(收小于开,o,(o+c)/2,7.5,0),colorff11ff;

stickline(收小于开,o,(o+c)/2,6,0),colorff33ff;

stickline(收小于开,o,(o+c)/2,5,0),colorff55ff;

stickline(收小于开,o,(o+c)/2,4,0),colorff77ff;

stickline(收小于开,o,(o+c)/2,3,0),colorff99ff;

stickline(收小于开,o,(o+c)/2,2,0),colorffbbff;

stickline(收小于开,o,(o+c)/2,1,0),colorffddff;

收大于开:=C<十天买卖 and c>open;

stickline(收大于开,c,(o+c)/2,7.5,0),color333333;

stickline(收大于开,c,(o+c)/2,6,0),color555555;

stickline(收大于开,c,(o+c)/2,5,0),color777777;

stickline(收大于开,c,(o+c)/2,4,0),color999999;

stickline(收大于开,c,(o+c)/2,3,0),colorbbbbbb;

stickline(收大于开,c,(o+c)/2,2,0),colordddddd;

stickline(收大于开,c,(o+c)/2,1,0),colorffffff;

LL:=LLV(C,100);

TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);

平台支撑:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);

stickline(平台支撑,c,(o+c)/2,7.5,0),color005555;

stickline(平台支撑,c,(o+c)/2,6,0),color006666;

stickline(平台支撑,c,(o+c)/2,5,0),color007777;

stickline(平台支撑,c,(o+c)/2,4,0),color009999;

stickline(平台支撑,c,(o+c)/2,3,0),color00bbbb;

stickline(平台支撑,c,(o+c)/2,2,0),color00dddd;

stickline(平台支撑,c,(o+c)/2,1,0),color00ffff;

平台压力:=IF(Cref(OPEN,1),ref(close,1),0);

stickline(平台压力,o,(o+c)/2,7.5,0),color003300;

stickline(平台压力,o,(o+c)/2,6,0),color005500;

stickline(平台压力,o,(o+c)/2,5,0),color007700;

stickline(平台压力,o,(o+c)/2,4,0),color009900;

stickline(平台压力,o,(o+c)/2,3,0),color00bb00;

stickline(平台压力,o,(o+c)/2,2,0),color00dd00;

stickline(平台压力,o,(o+c)/2,1,0),color00ff00;

yl:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);

FT:=BARSLAST(yl);

YLX:=REF(yl,FT);

bt:=IF(Cref(OPEN,1),ref(C,1),0);

XFT:=BARSLAST(bt);

XYLX:=REF(bt,XFT);

平台调下:=CROSS(XYLX,C);

平台突破:=CROSS(C,YLX);

DRAWICON(平台突破,L* 0.93,7),ALIGN1,VALIGN2;

DRAWICON(平台调下,H,8),ALIGN1,VALIGN2;

VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;

VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);

VAR5:=LLV(LOW,34);

VAR6:=HHV(VAR4,34);

VAR7:=IF(LLV(LOW,56),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

主力进场:=VAR8>REF(VAR8,1);

进场:=ref(主力进场,1);

DRAWTEXT(进场 and 平台突破 ,L * 0.97,'进'),ALIGN1,COLOR0000FF;

DRAWTEXT(进场 and 平台突破 ,L * 0.94,'场'),ALIGN1,COLOR0000FF;

DRAWICON(进场 and 平台突破 and L=支撑位,L* 0.93,1),ALIGN1,VALIGN2;

机构增仓:=EXTDATA(1);

大户增仓:=EXTDATA(2);

散户增仓:=EXTDATA(3);

增仓风向:=机构增仓+大户增仓;

增仓:=ref(cross(增仓风向,0)and c<十天买卖,1);

进:=cross(增仓风向,机构增仓) or 增仓;

DRAWICON(进 and 增仓风向>0 and 机构增仓>0 and C>十天买卖,L* 0.95,12),ALIGN1,VALIGN2;

出:=cross(机构增仓,增仓风向);

DRAWICON(出 and C<十天买卖,H* 1,13),ALIGN1,VALIGN2;

DRAWTEXTREL(800,100,'机构增仓:'+NUMTOSTRN(机构增仓,0)),LINETHICK2,ColorFFFFFF;

DRAWTEXTREL(800,150,'大户增仓:'+NUMTOSTRN(大户增仓,0)),LINETHICK2,ColorFFFFFF;

DRAWTEXTREL(800,200,'散户增仓:'+NUMTOSTRN(散户增仓,0)),LINETHICK2,ColorFFFFFF;

STICKLINE(V>=HHV(V,62),OPEN,CLOSE,3,0),COLOR00FFFF;


 

关于本站 | 法律声明 | 广告合作 | RSS订阅

Copyright © 湖南携景网络技术有限公司 gongshi8.com .All Rights Reserved .琼ICP备13000505号-2