公式吧 公式吧大智慧公式、大智慧股票公式.域名www.gongshi8.com公式吧

loadding...

(选股)多指标共振选股指标—大智慧公式

发布时间: 2017-01-06 14:38

(选股)多指标共振选股指标—大智慧公式  源码如下:

(选股)多指标共振选股指标—大智慧公式

N:=9;

N1:=6;

M:=14;

AAATYP := (HIGH + LOW + CLOSE)/3;

AAA1:=(AAATYP-MA(AAATYP,M))/(0.015*AVEDEV(AAATYP,M));

C1:=SMA(AAA1,3,1);

C2:=SMA(C1,3,1);

C3:=3*C1-2*C2;

CB1:=EMA(C3,5);

CB2:=REF(CB1,1);

LC := REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;

RSI:=(RSI1-50)*5;

R1:=SMA(RSI,3,1);

D1:=SMA(R1,3,1);

J1:=3*R1-2*D1;

RR1:=EMA(J1,5);

RR2:=REF(RR1,1);

RR:=RR1>RR2;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,3,1);

K1:=(K-50)*5;

K2:=SMA(K1,3,1);

D2:=SMA(K2,3,1);

J2:=3*K2-2*D2;

BB1:=EMA(J2,5);

BB2:=REF(BB1,1);

三宝:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,COLORGREEN,NODRAW;

STICKLINE(三宝,5,0,3,0)COLORGREEN;

{极地上涨}

VA1:=HHV(HIGH,9)-LLV(LOW,9); 

VA2:=HHV(HIGH,9)-CLOSE;

VA3:=CLOSE-LLV(LOW,9);

VA4:=VA2/VA1*100-70;

VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VA6:=(CLOSE+HIGH+LOW)/3;

VA7:=SMA(VA3/VA1*100,3,1);

VA8:=LLV(LOW,34);

VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);

VARA:=IF(VA9>100,VA9-100,0);

VARB:=HHV(HIGH,34);

VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);

VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);

VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;

VARF:=MA(VARE,3);

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-CLOSE;

VAR3:=CLOSE-LLV(LOW,9);

VAR4:=((VAR2)/(VAR1))*(100)-70;

VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);

VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);

VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);

VAR8:=LLV(LOW,34);

VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);

VAR10:=IF((VAR9>100),VAR9-100,0);

VAR11:=HHV(HIGH,34);

B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);

领先:=EMA(B1,5);

生命线:=EMA(VARD,1);

V1:=MA(C,5)=HHV(MA(C,5),20);

V2:=MA(C,5)>MA(C,10);

V3:=MA(V,5)>MA(V,40)*1.01;

V4:=COUNT(MA(C,1)>REF(C,1),2)=2;

VV:=V1 AND V2 AND V3 AND V4;

A1:=EMA(CLOSE,8);

A2:=EMA(A1,20);

A3:=CROSS(A1,A2);

A4:=A1<EMA(CLOSE,120);

A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*

SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1);

安全位:=20;

低位转强:=CROSS(A5,安全位);

开始拉升:=CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O;

A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);

极地上涨:=A6;

极地:开始拉升>0 AND 开始拉升<400 OR 极地上涨>0 AND 极地上涨<400

OR (低位转强>0 AND 低位转强<400) OR (低位转强>0),COLORYELLOW,NODRAW;

STICKLINE(极地,10,15,3,0),COLORYELLOW;

{好底}

D:=EMA((C*3+H+L+O)/6,5);

买卖:=D,COLORGREEN,LINETHICK2;

A线:=HHV(D,13)COLORYELLOW,LINETHICK2;

B线:=LLV(D,13)COLORYELLOW,LINETHICK2;日平:="MACD.MACD#DAY"(12,26,9);

周平:="MACD.MACD#WEEK"(12,26,9);

JC:=(A线-B线);

壹:=COUNT(JC>REF(JC,1)AND A线>REF(A线,1),5)=1 AND JC>REF(JC,1)AND A线>REF(A线,1)AND D>=REF(D,1);

G1:=FILTER(壹=1,10);

G2:=BARSLAST(G1>0);

G3:=IFF(G2>0 AND G2<=10,1,0)=1 AND ((C-REF(C,G2))/REF(C,G2))*100>=5;

概壹:=(SUM(FILTER(G3,10),0)/SUM(G1>0,0))*100;

加1:=COUNT(日平>=0 AND 周平>=0,5)=1 AND 日平>=0 AND 周平>=0;

加2:=FILTER(D=A线 AND REF(D,1)<REF(A线,1)AND REF(D,2)<REF(A线,2),10);

①:=FILTER(加1=1,10);

②:=BARSLAST(①>0);

③:=IFF(②>0 AND ②<=10,1,0)=1 AND ((C-REF(C,②))/REF(C,②))*100>=5;

概加1:=(SUM(FILTER(③,10),0)/SUM(①>0,0))*100;

好底:FILTER(COUNT(D=B线,3)>=2 AND D>B线,5),COLORBLUE,NODRAW;

STICKLINE(好底,15,20,3,0),COLORBLUE;

{抄底}

MMM:=1;

SVOL:=INTPART(SUM(V,0)/CAPITAL);

TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;

S1:=BARSLAST(TJ0)+1;

TJJ2:=S1<REF(S1,1);

S2:=IF(TJJ2,REF(S1,1)+1,S1);

S3:=SUM(TJJ2,0);

ZK1:="KD.K#WEEK"(9,3,3);

ZD2:="KD.D#WEEK"(9,3,3);

ZF1:="MACD.DIF#WEEK"(12,26,9);

ZA2:="MACD.DEA#WEEK"(12,26,9);

换手:=V/CAPITAL*100,LINETHICK0;

JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)<30;

抄底:EXIST(JCD,MMM),COLORCYAN,NODRAW;

STICKLINE(抄底,20,25,3,0),COLORCYAN;


 

关于本站 | 法律声明 | 广告合作 | RSS订阅

Copyright © 湖南携景网络技术有限公司 gongshi8.com .All Rights Reserved .琼ICP备13000505号-2