公式吧 公式吧大智慧公式、大智慧股票公式.域名www.gongshi8.com公式吧

loadding...

(主图)股神擒牛主图指标—同花顺公式

发布时间: 2017-01-09 15:22

(主图)股神擒牛主图指标—同花顺公式  源码如下:

(主图)股神擒牛主图指标—同花顺公式

回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);

经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;

MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));

MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));

MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));

回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));

上线:=SMA(C,6.5,1);

一号支撑线:SMA(C,14.5,1);

上线1:=SMA(C,3,1);

一号支撑线1:=SMA(C,8,1);

上线2:=SMA(C,3.5,1);

DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;

BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;

UPR:=BBI+3*STD(BBI,13),LINETHICK2;

DWN:=BBI-3*STD(BBI,13);

安全:=MA(CLOSE,55),LINETHICK2;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;

A7:=(2*C+H+L)/4;

操作:MA(A7,5),colorblue,LINETHICK2;

操作1:=MA(A7,5)*1.03,LINETHICK2;

操作2:=MA(A7,5)*0.97,LINETHICK2;

DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),coloryellow;

VAR1:LLV(A7,21);

VAR2:HHV(A7,30);

DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 and="" close="">VAR1,LOW *0.98,'见底' ),coloryellow;

YCX:=操作>=REF(操作,1);

H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);

L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);

DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),coloryellow;

SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);

SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);

M1:=1000*操作/一号支撑线<=1015 and="">=975;

M2:=1000*一号支撑线1/一号支撑线<=1020 and="">=980;

M3:=1000*上线/一号支撑线<=1015 and="">=985;

DRAWTEXT(IF(COUNT(CLOSE6/10 AND

COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND

REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND

OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,coloryellow;

D:=MA(CLOSE,89)-MA(CLOSE,10)/3;

DRAWTEXT(IF(CLOSEMA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08

AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),colorbrown;

RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;

K:=SMA(RSV,3,1);

D1:=SMA(K,3,1);

J:=3*K-2*D1;

VAR3:=(2*CLOSE+HIGH+LOW)/3;

VAR4:=EMA(EMA(EMA(VAR3,4),4),4);

E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;

F:=MA(E,3)+0.03;

G:=MA(E,1);

DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),colorgreen;

DRAWICON(CROSS(G,F),LOW *0.9,9),coloryellow;

DRAWTEXT(CLOSE>OPEN AND H1<C AND OVAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),colorred;

DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),coloryellow;

DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),colorred;

DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),colorred;

DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),colorred;

STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),colorred;

STICKLINE(CREF(C,1),C,O,3,0),COLORFFCC00;

STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;

STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.7,0 ),COLOR000077;

STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.1,0 ),COLOR000099;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;

STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;

STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;

STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),colorwhite;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;

STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;

STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),colorcyan;

STICKLINE(CO,C,O,3,0),COLORFFCC00;

STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;

STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;

STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;

STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;

STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;

STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;


 

关于本站 | 法律声明 | 广告合作 | RSS订阅

Copyright © 湖南携景网络技术有限公司 gongshi8.com .All Rights Reserved .琼ICP备13000505号-2