公式吧 公式吧大智慧公式、大智慧股票公式.域名www.gongshi8.com公式吧

loadding...

(量比)四量指标—通达信公式

发布时间: 2017-01-10 16:15

(量比)四量指标—通达信公式 源码如下:

(量比)四量指标—通达信公式

时间:DATE+1900/00/00,NODRAW ,COLORWHITE;

MID1:=(3*CLOSE+LOW+OPEN+HIGH)/6;

牛线:=(20*MID1+19*REF(MID1,1)+18*REF(MID1,2)+17*REF(MID1,3)+16*REF(MID1,4)+15*REF(MID1,5)+14*REF(MID1,6)+13*REF(MID1,7)+12*REF(MID1,8)+11*REF(MID1,9)+10*REF(MID1,10)+9*REF(MID1,11)+8*REF(MID1,12)+7*REF(MID1,13)+6*REF(MID1,14)+5*REF(MID1,15)+4*REF(MID1,16)+3*REF(MID1,17)+2*REF(MID1,18)+REF(MID1,20))/210,COLORGREEN{COLORRED};

马线:=MA(牛线,3),COLORMAGENTA{COLORYELLOW};

GB:=(C-牛线);

换手:=V*100/CAPITAL;

主:=MA(换手,5);

大:=MA(换手,12);

中:=MA(换手,34);

散:=MA(换手,55);

均:=(主+大+中+散)/4;

GBB:=(主-散);

GB1:=GB+GBB;

STICKLINE(GB1>=0,2.5,4,4,0),COLORRED{COLOR017700},LINETHICK2;

STICKLINE(GB1<0,2.5,4,4,0),COLORGREEN{COLOR000099},LINETHICK2;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,3.2,0),'散户'),COLORWHITE;

AA:=MAX(MA(C,60),MA(C,120));

BB:=MIN(MA(C,60),MA(C,120));

成交量:=V,COLORWHITE,LINETHICK0;

Q:=EMA(V,5);

Q1:=EMA(V,50);

OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

OBV1:=EMA(OBV,5);

OBV2:=EMA(OBV,50);

W:=(Q-Q1)*0.00001;

W1:=(OBV1-OBV2)*0.000001;

W2:=W+W1;

STICKLINE(W2>=0,0.3,1.8,4,0),COLORRED{COLOR017700},LINETHICK2;

STICKLINE(W2<0,0.3,1.8,4,0),COLORGREEN{COLOR000099},LINETHICK2;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,1,0),'游资'),COLORWHITE;

{R:=0;}

E:=MAX(MA(C,45),MA(C,90));

FF:=MIN(MA(C,45),MA(C,90));

C1:=10000*CLOSE/INDEXC;

O1:=10000*OPEN/INDEXO;

H1:=10000*HIGH/INDEXH;

L1:=10000*LOW/INDEXL;

LL:=IF(L1<C1 AND L1<O1,L1,MIN(C1,O1));

HH:=IF(H1>C1 AND H1>O1,H1,MAX(C1,O1));

A:=EMA(C1,5);

B:=EMA(C1,12);

D:=EMA(C1,30);

XX:=EMA(C1,35);

F:=EMA(C1,7);

均量:=(A+B+D)/3;

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV11:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

MAOBV:=MA(OBV11,30);

MTR:=EMA(EMA(EMA(CLOSE,12),12),12);

TRIX:=(MTR-REF(MTR,1))/REF(MTR,1)*100;

MATRIX:=MA(TRIX,9) ;

MIDA:=CLOSE-MIN(REF(CLOSE,1),LOW);

MIDB:=IF(CLOSE<REF(CLOSE,1),CLOSE-MAX(REF(CLOSE,1),HIGH),0);

WAD:=SUM(IF(CLOSE>REF(CLOSE,1),MIDA,MIDB),0);

MAWAD:=MA(WAD,30);

JB:=(OBV11-MAOBV)*0.000001+(A-XX);

机构:=A-XX;

STICKLINE(机构>=0,-1.9,-0.4,4,0),COLORRED{COLOR017700},LINETHICK2;

STICKLINE(机构<0,-1.9,-0.4,4,0),COLORGREEN{COLOR000099},LINETHICK2;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,-1.2,0),'机构'),COLORWHITE;

J:=MAX(MA(C,30),MA(C,60));

K:=MIN(MA(C,30),MA(C,60));

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+

16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+

13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+

10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+

7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+

4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;

MADKX:=MA(DKX,6);

MDD:=(DKX-MADKX)*1.2;

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,6)-EMA(V1,55); 

V3:=EMA(V2,6); 

V4:=2*(V2-V3)*5.5; 

V5:=(V2-V3)*0.06;

V6:=MDD+V5;

STICKLINE(V6>=0,-4.1,-2.6,4,0),COLORRED{COLOR017700},LINETHICK2;

STICKLINE(V6<0,-4.1,-2.6,4,0),COLORGREEN{COLOR000099},LINETHICK2;

DRAWTEXT(ISLASTBAR=1,IF(V>=0,-3.4,0),'主力'),COLORWHITE;

BQIUV:(GB1),COLORWHITE,NODRAW;

BQIUSV:(W2),COLORYELLOW,NODRAW;

WWV:(A-XX),COLORBLUE,NODRAW;

XEV:(V6),COLORGREEN,NODRAW;


 

关于本站 | 法律声明 | 广告合作 | RSS订阅

gongshi8.com .All Rights Reserved .琼ICP备13000505号-2 联系QQ:526584426